Platform Performance Issue

Incident Report for Incident IQ Platform Status

Resolved

Our internal monitoring and testing confirm that the platform and all services are fully restored and operating normally. We apologize for any disruption this issue may have caused and appreciate your patience while our team worked on a fix. If you continue to experience any issues, please don't hesitate to reach out to our support team.
Posted Aug 11, 2026 - 15:03 EDT

Monitoring

Our engineering team has identified the root cause and applied a fix. We are actively monitoring the results, and services are recovering.
Posted Aug 11, 2026 - 14:15 EDT

Investigating

We want to inform you that we are currently experiencing a performance issue that may impact your experience on our platform. Our engineering team is actively investigating the issue, and we are working to resolve it as quickly as possible.

We apologize for any inconvenience this may cause and appreciate your patience. We will keep you updated on our progress and notify you as soon as the platform is performing at optimal levels.
Posted Aug 11, 2026 - 14:09 EDT
This incident affected: Platform.