Intermittent Performance Issue

Incident Report for Incident IQ Platform Status

Resolved

Apologies for the inconvenience and thank you for your patience This incident has been resolved. If you experience any additional problems please reach out to Support.
Posted Sep 02, 2025 - 10:10 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 02, 2025 - 09:35 EDT

Investigating

We are experiencing some intermittent site responsiveness issues that are causing slow page loading times. Our Engineering Team is currently investigating the cause and working on a solution. We will provide updates here as soon as they are available. Apologies for the inconvenience and thanks for your patience.
Posted Sep 02, 2025 - 09:27 EDT
This incident affected: Platform.